2 items per row mobile portrait view not working


I have the JM BookShop theme installed.

1. When I set the JM Products extension to display items in 2 columns when in mobile portrait mode, it does not work. Mobile portrait mode only ever displays items in one column for grid view.

2. Further, when set to show two items / row (2 columns) on mobile portrait, the “Top 10 Books” block displays four rows deep, instead of two when in landscape mode (desktop mode).


I tried a suggestion mentioned in this thread, https://www.ubertheme.com/question/display-2-products-per-row-on-mobile-view/ (modifying the layout-mobile-portrait.css file by changing it to read:

.products-grid li.item {
  width: 100% !important; --> width: 50% !important;

but it made no difference.

Please help.


9 answers

Profile photo of Ziven Staff 92660.00 $tone April 4, 2017

Hi Paul,
#1: I’m not sure what exactly you want to in here. Please let me know more details.
#2: It will need more bit customized. Please share the FTP i will check and let you know. 
Best Regards,

Profile photo of Paul Chapman 470.00 $tone April 4, 2017

Hi Ziven.

In regard to #1, when I set the “# Number of items/rows (or columns) on mobile portrait” to “2”, via the JM Products configuration page, if I hold my phone in portrait mode while looking at a product list in grid layout, I would expect to see two columns of items, each column at 50% of the screen width: 

Gifts for God's People   "Fear Not Little Flock"

"Fear Not Little Flock"   The Vision Study Bible KJV

Instead I see only one column of books that is 100% of the width of the screen:

 Great Relationships Series - 2 Marriage

Great Relationships Series - 3 The Family


So how do I get the first view (a grid view that is 2 columns wide) to display in portrait mode on my mobile phone? I thought that is what the JM Products config page was allowing me to set under the “Mobile Settings” section.

Regarding #2, I already sent you my FTP details for the first question I had.


Profile photo of Ziven Staff 92660.00 $tone April 4, 2017

Hi Paul,
Thanks for sent me the FTP.
#1: What exactly the page you want to show like? About the JM config maybe it has been overwriting in the code that why it not working like you want to.  Please tell me the block or the listed product you want to show I tell you why.
#2: http://prntscr.com/es9brx I see it show like this via mobile. What exactly you want in here? I do not see the issue. 
Hope you understand. 
Best Regards,

Profile photo of Paul Chapman 470.00 $tone April 4, 2017

#1 Look on any page that displays a items in a grid view. Like these: 


#2 To see the issue, you have to set the columns to 2 or more in mobile portrait mode. I set this at “2” just now. Now, go to your DESKTOP web browser (not on your mobile). Open the “Books” mega menu. Here’s what I see:


The “Book of the Week” normally is just one (1) book. But now there are four books showing (???).

Also, last night, using a DESKTOP browser (not on your mobile)  “Top 10 Books” showed four rows instead of the normal two rows

Set JM Products under Mobile Settings to show in 2 columns when in Mobile Portrait mode. “Top 10” block on the Desktop browser looked like this last night: https://1drv.ms/i/s!Am7he4_k_wV7ovcQw35TV1Js4EU6AQ

I don’t know what is going on here.

Profile photo of Ziven Staff 92660.00 $tone April 5, 2017

Hi Paul,
#1: We will need time to fix this issue via DEV. We will let you know soon and update for you if the issue has been resolved.
--> Here in my end: http://prntscr.com/eskujv It only one. 
--> Here in my end: http://prntscr.com/eskuop It shows very nice. 
I think you can try to clear the cache browser.
Please let me know if you need help more.
Best Regards,

Profile photo of Paul Chapman 470.00 $tone April 6, 2017

Thanks for this Ziven.


#1. I’ll leave this question open till you can update the DEV fix for this.

#2. No worries. All is good now. Thanks very much 🙂

Kind regards,


Please login or Register to Submit Answer

Written By