custom.css not run last!


I use Joomla v3.1.5 with the blank template v1.4.1 and, among other great extensions, the JA_Slideshowlite v1.1.7

It seems that part of the mod_jaslideshowlite.css is loaded AFTER the corresponding part in custom.css (see screendump).
Attachment 30124

When I disable the background line, by using FireBug, the background line (#BB2B2B) of custom.css is shown! (see screendump)
Attachment 30125

The rest of custom.css is run correctly.

Can anyone tell me what to do, so that the complete custom.css is run last?

Thanks in advance for suggestions/tips.

6 answers

pb66 0.00 $tone September 17, 2013

I’m not a programmer, but from experience I would say that you shouldn’t be able to read the actual module.css names in firebug.

This would indicate to me that either the setting Extensions-Template Manager // General tab need to be changed.

Try changing either the "enable development mode" or "optimise css" to yes or no (opposite to what they are now!)

This should recompile the .css files to random (optimised) names that you can never figure out where they come from.

During this optimisation process you should find that your custom.css code will be loaded last.

To my understanding T3 is operating at 3 levels.

  1. LESS files where you can easily change parameters across the entire site with one change
  2. .css files that are compiled from your LESS files when you turn off development mode
  3. Optimised (minified and compressed) .css files that run in the T3 Cache when you turn on ‘optimise css’

To get maximum performance you obviously optimise css to get your site to run best! But there are the tools in the backend to enable you to see changes at different levels of programming depending on what you are trying to achieve.

Let me know if this helps!


d56webdesign 0.00 $tone September 17, 2013

Hi pb66,

Thank you for our suggestion but for now I need to see the actual information in css files to make the neccessary changes. Later on I will set ‘Optimise CSS’ to Yes.

Either changing "development mode" to yes nor "optimise css" to yes worked. As you can see in the screendump.
Attachment 30138
I do not make changes to the LESS files but I even tried ‘Compile LESS to CSS’ but that also did not do the trick.

The only thing I can think of to do, is make the change directly in the mod_jaslideshowlite.css
But that is not the way I like it to work because the css mechanisme should override the settings.

d56webdesign 0.00 $tone September 18, 2013


Thank you for your respons. It WORKED!!

But I’m curious what the difference is between with or without the ‘!important’ remark.
I’m not a programmer so if anyone can explain this in plain English I would be grateful.

slavelle 0.00 $tone September 18, 2013

I think the deal with the custom.css file is that it will be last of all of the T3 framework stuff, but plugins and whatnot can still come after it. If they are calling their CSS in after the fact, the settings there will "win" over the custom.css ones unless you specify !important, which will make that setting take precidense, unless of course it is followed by another !important rule for the same or more specific setting later in the "cascade". Hope this helps you or someone else reading the post later.


This question is now closed

Written By