Fallback to JQueryUI Compat activated

Hi
In Chrome I am getting this warning:
compat.js:43 Fallback to JQueryUI Compat activated. Your store is missing a dependency for a jQueryUI widget. Identifying and addressing the dependency will drastically improve the performance of your site.
 
Using the method here:
https://magento.stackexchange.com/questions/293714/magento-2-console-notice-fallback-to-jqueryui-compat-activated
I get the following MegaMenu files using jquery/ui
Ubertheme/UbMegaMenu/view/adminhtml/templates/item/widget/form/renderer/fieldset/selectone.categories.phtml: ‘jquery/ui’,
Ubertheme/UbMegaMenu/view/adminhtml/web/js/ub-import-categories.js: ‘jquery/ui’,
Ubertheme/Base/view/adminhtml/web/js/ub-draggable-fields.js: ‘jquery/ui’
Ubertheme/Base/view/frontend/web/js/ajaxAddCart.js: ‘jquery/ui’,
Ubertheme/Base/view/frontend/web/js/ajaxCompare.js: ‘jquery/ui’
Ubertheme/Base/view/frontend/web/js/ajaxWishlist.js: ‘jquery/ui’
Ubertheme/Base/view/frontend/web/js/ubCountDown.js: ‘jquery/ui’
 
Can you advise if any of these instances can be changed to the specific JQuery UI module
 
Thanks
 
Ben

1 answer

Profile photo of Mall Staff 153110.00 $tone September 30, 2020
Public

Hi there,

In Chrome I am getting this warning:
compat.js:43 Fallback to JQueryUI Compat activated. Your store is missing a dependency for a jQueryUI widget. Identifying and addressing the dependency will drastically improve the performance of your site.

I get the following MegaMenu files using jquery/ui
Ubertheme/UbMegaMenu/view/adminhtml/templates/item/widget/form/renderer/fieldset/selectone.categories.phtml: ‘jquery/ui’,
Ubertheme/UbMegaMenu/view/adminhtml/web/js/ub-import-categories.js: ‘jquery/ui’,
Ubertheme/Base/view/adminhtml/web/js/ub-draggable-fields.js: ‘jquery/ui’
Ubertheme/Base/view/frontend/web/js/ajaxAddCart.js: ‘jquery/ui’,
Ubertheme/Base/view/frontend/web/js/ajaxCompare.js: ‘jquery/ui’
Ubertheme/Base/view/frontend/web/js/ajaxWishlist.js: ‘jquery/ui’
Ubertheme/Base/view/frontend/web/js/ubCountDown.js: ‘jquery/ui’
 
Can you advise if any of these instances can be changed to the specific JQuery UI module

Yes, I have checked and saw that warning message came from Magento 2.3.3 and it happened in the frontend context only. 

To clean that warning message, you can do steps as follows at your end:

1. For each JS file you mentioned above, please open it and find the code line:

'jquery/ui'

and replace it with: 

'jquery-ui-modules/core',
'jquery-ui-modules/widget'

2. After you changed all related JS files, you need to redeploy the static files of your site again.

Regards,
Mall.
 

#1

Please login or Register to Submit Answer

Written By

Comments