Is Megamall 1.0.9 compatible with magento 2.2.6?

1.0.9 looks to be compatible with 2.2.5 but can you confirm it works with 2.2.6?

11 answers

Profile photo of ubdev Staff 28400.00 $tone October 16, 2018
Public

Hi there, 
We’ve just released UB MegaMall v1.1.0 which is compatible with Magento 2.2.6. You can get this package from your profile now. 
Hope that helps. 
Regards,
Ubertheme team

#1
Profile photo of zappautomation 1390.00 $tone October 16, 2018
Public

Thanks, i have just downloaded and trying on our Dev site, but I get this error after i run php bin/magento setup:static-content:deploy -t Ubertheme/megamall -f
http://prntscr.com/l6qv0x
 
This is the process i used.
Uploaded all of the files.
Step 1: php bin/magento maintenance:enable
Step 2: php bin/magento setup:upgrade
Step 4: rm -rf var/di/* var/generation/* var/cache/* var/log/* var/page_cache/* var/session/* var/view_preprocessed/* pub/static/frontend/Ubertheme/megamall/*
Step 4: php bin/magento setup:static-content:deploy -t Ubertheme/megamall -f (Make sure you are using developer (or default) mode)
Step 5: php bin/magento cache:flush
step 6: php bin/magento maintenance:disable
Step 7: clear your browser cache
 
 

#2
Profile photo of Ziven Staff 84830.00 $tone October 17, 2018
Public

Hi There,

Thanks, i have just downloaded and trying on our Dev site, but I get this error after i run php bin/magento setup:static-content:deploy -t Ubertheme/megamall -f
http://prntscr.com/l6qv0x

Please go to M2 root folder and delete this file: app/design/frontend/Ubertheme/megamall/Ubertheme_UbMegaMenu/css/source/module/_var.less
Once done re-compile LESS as CSS following steps as you did. If the issue still persists, do let me know then. 

Best Regards,
Ziven.

#3
Profile photo of Ziven Staff 84830.00 $tone October 17, 2018
Public

Hi There,

Thanks, that got rid of some of the errors.  I still have one error.
http://prntscr.com/l6z9f2

Please provide me admin and SSH credentials of your M2 instance, I need to debug further.
PS. Make sure you mark your reply private, then it’s safe to share your site info here.

Best Regards,
Ziven.
 

#5
Profile photo of Ziven Staff 84830.00 $tone October 18, 2018
Public

Hi There,

Thanks, that got rid of some of the errors.  I still have one error.
http://prntscr.com/l6z9f2

I debugged and found an issue associated with the module/_var.less that led to the deploy issue. We removed this file: app/design/frontend/Ubertheme/megamall/Ubertheme_UbMegaMenu/web/css/source/_module.less
Further, I also updated the extension version for: dev.zappautomation.co.uk/html/app/code/Ubertheme/UbContentSlider
Your site is working fine now, please check again. 
Best Regards,
Ziven.

#7
Profile photo of zappautomation 1390.00 $tone October 18, 2018
Public

Thank you, I have also noticed another problem.
On a few of the side menus in the category pages when i click up the menu, i get an exception.
I dont know if it is theme related?
If i open any of these links i get an exception.
http://prntscr.com/l7ef4g
http://dev.zappautomation.co.uk/pneumatic-products/pneumatic-fittings-and-accessories/push-in-fittings.html
 
However if go go back to the previous page, the links work.

#8
Profile photo of Ziven Staff 84830.00 $tone October 18, 2018
Public

Hi There,

On a few of the side menus in the category pages when i click up the menu, i get an exception.
I dont know if it is theme related?

This is known issue of Magento, you can check this thread for further information:  https://github.com/magento/magento2/issues/13823
Meanwhile, I highly recommend you upgrade to the latest Magento 2.2.6. I noticed that you’re using M2.2.4 now.

Best Regards,
Ziven.

#9
Profile photo of ubdev Staff 28400.00 $tone October 18, 2018
Public

Hi there, 
Yes, please move forward with the ugprading. If you run across any issue related to our products, please get back to us here.
Regards,
Ubertheme team

#11

Please login or Register to Submit Answer

Written By

Comments