Magento 2.4.5 support (i.e. PHP 8.1 Support)

Hi there,
I just bought the above module, since it did a reasonable job 2 years ago. Now I could install it (although composer.json states it is only supported for few PHP-Versions: 

"php": "~7.1.3||~7.2.0||~7.3.0",

Anyhow, opening the Magento Backend I got lots (!) of deprecation errors.
Do you have a newer release (if so when is it expected?) or are you abandoning support for PHP 8.1? 
Best regards,
Willi
 

5 answers

Profile photo of Mall Staff 181800.00 $tone September 21, 2022
Public

Hi there,

Do you have a newer release (if so when is it expected?) or are you abandoning support for PHP 8.1? 

The latest release of our module (v3.2.7) is compatible with PHP 8.1.

At this time, we have not yet tested our migration tool with Magento open source v2.4.5, however you can try it at your end and contact us if you need further assistance.
 

Regards,
Mall.
 

#1
Profile photo of Mall Staff 181800.00 $tone September 22, 2022
Public

Hi there,

well, no! v3.2.7 is the version I have and no, as I said, lots of deprecation errors.

Please provide me with information about your instance:
+ Admin credentials and URL to the backend
+ SSH credentials and the path to the M2 folder

I will be able check further and help you out once knowing more.
 

Regards,
Mall.

#3
Profile photo of Mall Staff 181800.00 $tone September 23, 2022
Public

Hi there,

For the moment I can’t do so, since I am working locally. I already fixed lots of the errors myself. Now I am looking for another one..

So you can try following these simple steps:

1. Open the PHP file at the path: pub/ub-tool/index.php
and find to code line:

ini_set('display_errors', 1);

and replace it with this code line:

// ini_set('display_errors', 1);
error_reporting(E_ERROR | E_PARSE);

2. Once done, check for the issue you mentioned again.
 

Regards,
Mall.

#5

Please login or Register to Submit Answer

Written By

Comments