PHP 7.2 & 7.3 compatibility

Hi,
 
We bought the UB Mega Menu extension yesterday but installing via composer failed because of the php version in composer.json.
On this project (M2.3.4) we use PHP 7.2 but on some sites we already use 7.3.
How come the extensions are not yet updated for 7.2 minimum? Is it safe for us to alter the composer file?
 
Thanks, Klaus

5 answers

Profile photo of Mall Staff 184060.00 $tone March 5, 2020
Public

Hi Klaus,

How come the extensions are not yet updated for 7.2 minimum? Is it safe for us to alter the composer file?

For compatibility with your installation via Composer, you can manually change that information in the composer.json file of our module(app/code/Ubertheme/UbMegaMenu/composer.json):
Find:

"php": "~5.5.0|~5.6.0|7.0.2|~7.0.6|~7.1.0",

replace it with:

"php": "~5.5.0|~5.6.0|7.0.2|~7.0.6|~7.1.0|~7.2.0|~7.3.0",

Hope that helps. 
 
PS. For any additional question you might have, please help to submit a ticket under the paid profile at Ubertheme, since our technical support requires active subscription. 
 
Regards,
Mall.
 

#1
Profile photo of Klaus De Buysser 30.00 $tone March 5, 2020
Public

Ok thanks Mall.
So that means the module is tested and works completely fine on 7.3 but the composer file is not yet updated to reflect this?
Thx.
Any future questions will indeed be submitted under the paid profile. That person is unfortunately not at the office today. 

#2
Profile photo of ubdev Staff 98350.00 $tone March 5, 2020
Public

Hi Klaus,
 
Yes, we see. Regarding PHP 7.3, it’s a pity that we have not tested our module with it yet. 
 
Anyway, please go ahead with that PHP version. If there are any issues when working with our module, please let us know, we will work closely with you then.
 
Regards,
Ubertheme team

#3
Profile photo of ubdev Staff 98350.00 $tone March 5, 2020
Public

Hi Klaus,
 
Our UB Mega Menu module is stable with PHP 7.1 though. 
 
If your project requires PHP 7.2 or PHP 7.3, please use it with that version at your end. We will work closely with you in case of any issue associated with those two PHP versions. 
 
Regards,
Ubertheme team

#5

Please login or Register to Submit Answer

Written By

Comments