/ub-tool/protected/runtime" is not valid.

Hi,
Expection thrown: 
throw new CException(Yii::t(‘yii’,’Application runtime path “{path}” is not valid. Please make sure it is a directory writable by the Web server process.’,
 
All folders in ub-tool directory got 755 (i tried with 777 also, same situation).
Any idea what i should look for? 🙂
 
Regards,

6 answers

Profile photo of Mall Staff 181800.00 $tone August 30, 2022
Public

Hi there,

All folders in ub-tool directory got 755 (i tried with 777 also, same situation).
Any idea what i should look for?

It seems that your server has a special setting case and you have not installed our migration tool successfully yet.
Do you see the folder at the below path in your instance?
your_m2_root/pub/ub-tool/protected/runtime/
If yes, please make sure you set the correct permission for that folder.

After that if you still need further assistance, please provide me with information about your instance:
+ Admin credentials and URL to the backend
+ SSH credentials and the path to the M2 folder

I will help to check further for you then.
 

Regards,
Mall.

#1
Profile photo of elgrossisten 60.00 $tone August 30, 2022
Public

Hi,
 
Yes i can see the folder it’s populated with other directories and files. Permissions are set to 777 just to be sure. 

I will make a new reply that is private with login settings. 

Thank you in advance. 

#2
Profile photo of Mall Staff 181800.00 $tone August 30, 2022
Public

Hi there,

Yes i can see the folder it’s populated with other directories and files. Permissions are set to 777 just to be sure. 

I checked in your instance via SSH and saw the related folder path existing: http://prntscr.com/TLh2Z6UZrqWJ . However it seems to have incorrect permission.
I tried to change permission of that folder but the SSH credentials you provided here have no permission to change. 

You can try to change permission for folders and files in your M2 root folder by running the following commands in your M2 root folder via SSH terminal:

chown -R magento2:magento2 .
find . -type d -exec chmod 755 {} +;
find . -type f -exec chmod 644 {} +;

Once done, please check for the issue you mentioned again.
 

Regards,
Mall.
 

#4

This question is now closed

Written By

Comments