404 in admin / UB Data Migration Pro (CE) – 3.2.7

Uploaded, refreshed cache, static content deleted, but I still get this 404 error in the admin backend when clicking on the UB Data Migration Pro icon.

10 answers

Profile photo of Mall Staff 180840.00 $tone July 11, 2022
Public

Hi there,

Uploaded, refreshed cache, static content deleted, but I still get this 404 error in the admin backend when clicking on the UB Data Migration Pro icon.

Please note that if your web server is Nginx, you must do the extra configuration for Nginx as indicated in the guide of our module (readme.html file is included in your download package).

In case you still need further assistance, please provide me with information about your instance:
+ Admin credentials and URL to the backend
+ SSH credentials and the path to the M2 folder
I will help to check further for you then.
 

Regards,
Mall.

#1
Profile photo of Mall Staff 180840.00 $tone July 12, 2022
Public

Hi there,

and included this line in my nginx.conf
include /var/www/html/pub/ub-tool/nginx.conf;

The config line you mentioned was the wrong path: http://prntscr.com/YulDYjh8taQg
Please note that in your case, you must include the config file with the right path in the configuration file of your Nginx: /home/igna/Sites/magento/src/pub/ub-tool/nginx.conf
I’ve updated it for you: http://prntscr.com/8cF-A2t_wGFB
Also, you must restart your web server after your changes.
 

To restart all containers (I’m using Docker Magento to run this M2 instance), please run
cd /home/igna/Sites/magento/
bin/restart

I did run the CLI command to restart as you mentioned at my end: http://prntscr.com/WYnw8yq7CJoZ
However I couldn’t access your site after that. Please help to check your server settings further at your end.
 

Regards,
Mall.
 

#3
Profile photo of igna 190.00 $tone July 12, 2022
Public

The original path was correct.
The host directory

/home/igna/Sites/magento/src/

is “linked” to the container directory

/var/www/html/

After I reverted your change and restarted, site is up and running again.

The path you wrote was the host path /home/igna/Sites/magento/src/pub/ub-tool/nginx.conf

The docker container path was correct /var/www/html/pub/ub-tool/nginx.conf;

I was able to check the nginx configuration by running “nginx -T” and it showed that the ub-tool/nginx.conf was actually included.

If you want to get “inside” the nginx container, please run 

docker exec -it magento-app-1 sh

Then you will have a terminal prompt, and there you can run….

 nginx -T

There you will see that ub-tool/nginx.conf was loaded.
 
If you want a terminal on the Magento container, please run this command at the host prompt..

bin/bash

Please tell me if you want more information on how to deal with the docker containers.
 

#4
Profile photo of Mall Staff 180840.00 $tone July 12, 2022
Public

Hi there,

Please tell me if you want more information on how to deal with the docker containers.

Please recheck, I could not log in to the backend of your site now with the admin credentials you provided: http://prntscr.com/bl7QDyggMEhm
Also, I checked further via SSH, I saw the Nginx configuration file of your Magento2 is empty now: http://prntscr.com/q5RkglOAXwEt
And I did not see the source code of our module in your instance now.
Regards,
Mall.

#5
Profile photo of Mall Staff 180840.00 $tone July 12, 2022
Public

Hi there,

I also realized that issue before, but I don’t know how to solve it.

It seems your server has a special case. Normally to solve that issue, our users simply do the extra configuration for the Nginx with steps as indicated in readme.html (included in your downloaded package)
Regards,
Mall.

#10

Please login or Register to Submit Answer

Written By

Comments