Can't map existing stores?

So it appears, I can’t map my old stores to my new stores?

3 answers

Profile photo of ubdev Staff 79160.00 $tone January 25, 2021
Public

Hi Shaun, 
Could you please explain in more detail? Once understanding the context you refer to, we will get back to you then.
Regards,
Ubertheme team 

#1
Profile photo of Shaun Forsyth 20.00 $tone January 25, 2021
Public

We already configured our stores in this instance, all of the themes, plugins etc are configured. However the store id’s don’t match.
From memory (we have used you plugin before, now we are deciding if we can use again, or if we have to take a different apporach), you can’t choose which old store_id’s map to the new ones? or do you use the store codes? rather than Id’s

#2
Profile photo of Mall Staff 162290.00 $tone January 28, 2021
Public

Hi Shaun,
I am sorry for getting back to you this late. 

We already configured our stores in this instance, all of the themes, plugins etc are configured. However the store id’s don’t match.

 you can’t choose which old store_id’s map to the new ones?

It means that you have a M2 instance with third-party theme and modules with configuration enabled. And now, you want to use our migration tool to migrate data from a M1 DB to this M2 instance?

And you want to map the store Ids in M1 DB with the existing store Ids in the current M2 instance?
 
By default, our migration tool helps to map (merge) the default website, default Store, and default Store view only. You can check ‘MERGE DEFAULT WEBSITES’ setting in step #2 of our module to enable this.

Other mappings to other stores, store views will need extra tweak code (and with extra fee for this custom tweak).
 
I hope that helps. 
 
Regards,
Mall.

 

#3

Please login or Register to Submit Answer

Written By

Comments