indexer high number in backlog

Dear Support,
When I run this command I get following error message:
…………..
…………..
…………..
Product Categories                                  | Ready  | Schedule  | working (24094 in backlog) | 2019-01-03 23:53:37
…………..
…………..
…………..
 
Any idea how to fix this?
I tried php bin/magento indexer:reset but it doesnt solve the problem.
Thanks,
Best Regards,
Asad

  1. Profile photo of asadyarasadyar 630.00 $tone January 4, 2019
    Command I ran is:php bin/magento indexer:status php bin/magento indexer:status+-----------------------------------------------------+--------+-----------+----------------------------+---------------------+| Title | Status | Update On | Schedule Status | Schedule Updated |+-----------------------------------------------------+--------+-----------+----------------------------+---------------------+| Amasty Improved Sorting - Bestsellers | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:35 || Amasty Improved Sorting - Most Viewed | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:35 || Amasty Improved Sorting - Top Rated | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:35 || Amasty Improved Sorting - Wishlists | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:35 || Amasty: Efficient Order Export - Product Attributes | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:58 || Catalog Product Rule | Ready | Schedule | idle (0 in backlog) | 2019-01-03 23:53:38 || Catalog Rule Product | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:19 || Catalog Search | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:58 || Category Flat Data | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:12 || Category Products | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:18 || Customer Grid | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:29:57 || Design Config Grid | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:29:48 || Product Categories | Ready | Schedule | working (24094 in backlog) | 2019-01-03 23:53:37 || Product EAV | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:34 || Product Flat Data | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:12 || Product Price | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:47 || Stock | Ready | Schedule | idle (0 in backlog) | 2019-01-04 21:30:41 |+-----------------------------------------------------+--------+-----------+----------------------------+---------------------+

5 answers

Profile photo of Mall Staff 111120.00 $tone January 5, 2019
Public

Hi there,

Command I ran is
$ php bin/magento indexer:status

That is a CLI command to show the statuses of Magento’s indexers. So, what is the issue you want to mentioned?
Regards,
Mall.

#3
Profile photo of asadyar 630.00 $tone January 5, 2019
Public

When I run this command it shows:

Product Categories                                  | Ready  | Schedule  | working (24094 in backlog) | 2019-01-03 23:53:37
 
Product Categories indexer is working and (24094 in backlog) . 
I tried to run the indexer manually. But this backlog is not going away. and also when we add new product they don’t show up online even after cron run. Have to manually run the indexer.
I think this backlog is preventing cron to complete the indexing.
 
Please advice
Thanks,
Best Regards,
Asad

#4
Profile photo of Mall Staff 111120.00 $tone January 5, 2019
Public

Hi there,

I think this backlog is preventing cron to complete the indexing.

Yes, that is right. 

I tried to run the indexer manually. But this backlog is not going away

The index manual function update for the status of the indexer only. The Schedule Status depends on the cron job function.

and also when we add new product they don’t show up online even after cron run.

That relates to the settings of Magento’s cron job function at your end only. And it doesn’t related to our migration tool.
Also, you could learn more about the Magento’s cron job settings at below post:
https://devdocs.magento.com/guides/v2.3/config-guide/cli/config-cli-subcommands-cron.html
Regards,
Mall.
 
 

#5

Please login or Register to Submit Answer

Written By

Comments