Wavethemes: Admin not compatible with SUPEE 6788

Hi support-team,
the wavethemes Jmmegamenu plugin is in admin (backend) not compatible with SUPEE 6788. I get 404 page if i click on “Manage Menu Groups”. When I take a look in the plugin’s config.xml I see there is the old admin-router implementation which is not compatible with magento 1.9.2.2 anymore. Is the an update for this plugin?
But when I take a lookg at the other included plugins also

  • Wavethmes_Jmbasetheme and
  • JoomlArt_JmSlideshow

has still old admin-router-implementation.
Could you pleas give us fixed versions for this plugin. This would be gread.
Thanks for your reply in advance.
Best regards,
Hanna-Sophie Ungar

6 answers

Profile photo of Ziven Staff 100280.00 $tone August 12, 2016
Public

Hi Hanna,
Please PM me your site’s url, admin and ftp credentials, I’ll detect the root of issue for troubleshooting.
Best Regards,
Ziven.

#1
Profile photo of iwelt 40.00 $tone August 12, 2016
Public

Hi Ziven,
thanks for your fast reply.
At the moment the theme with this plugins is not on a staging system. Only on my local developement shop on my laptop.
I think the problem is the following:

<admin>
<routers>
<jmmegamenu>
<use>admin</use>
<args>
<module>Wavethemes_Jmmegamenu</module>
<frontName>jmmegamenu</frontName>
</args>
</jmmegamenu>
</routers>
</admin>

Since SUPEE-6788 (see: https://magento.com/security/patches/supee-6788-technical-details) this had to change.

Have we get a old version?


#2
Profile photo of iwelt 40.00 $tone August 12, 2016
Public

The Magento-Version in config.xml of Wavethemes_Jmmegamenu is 0.1.3.
For the other plugins:

  • Wavethemes_Jmbasetheme: 0.1.1
  • JoomlArt_Slideshow: 1.1.1
#3
Profile photo of Ziven Staff 100280.00 $tone August 12, 2016
Public

Hi There,
Please follow like this doc: https://www.ubertheme.com/magento-updates/manual-update-magento-1922/
I think you did not add permission for the block when you upgraded the theme.
If you still can’t resolve please put to online I will help you detect. For now i can’t help you because I’m not sure exactly you see in the dev mode.
Hope you understand.
Best Regards,
Ziven.

#4
Profile photo of iwelt 40.00 $tone August 12, 2016
Public

Hi Ziven,
this blocks I had add to Permissions->Blocks.
But my problem is not the frontend, but the backend router from megamenu. At magento 1.9.2.2 with included SUPEE-6788 I think following way to set admin router is not possible anymore:
 

<admin>
<routers>
<jmmegamenu>
<use>admin</use>
<args>
<module>Wavethemes_Jmmegamenu</module>
<frontName>jmmegamenu</frontName>
</args>
</jmmegamenu>
</routers>
</admin>

Only this way like in your JoomlArt_JmProducts-Plugin is possible now:
<admin>
<routers>
<adminhtml>
<args>
<modules>
<JoomlArt_JmProducts before="Mage_Adminhtml">JoomlArt_JmProducts</JoomlArt_JmProducts>
</modules>
</args>
</adminhtml>
</routers>
</admin>

Could you please give as a fixed version for admin routers and controllers with resulting update-layout like for JoomlArt_JmProducts?

With this I would be very glad.

Thanks for your response in advance.


#5
Profile photo of Ziven Staff 100280.00 $tone August 15, 2016
Public

Hi There,
Please go to admin -> System -> Configuration -> Admin and enable like this pics. http://i.prntscr.com/54f35251b5d6451e9e9016d309e0a188.png
Best Regards,
Ziven.

#6

Please login or Register to Submit Answer

Written By

Comments