adding xml in default.xm file does not work

Hi,
I am unable to see the mega menu on the other page at https://joomgi.com/sewyeahquilting/ when I added the xml to Magento_Theme/default.xml.  I had to instead add the short code to the cms home page in order to at least get the menu to show on the landing page.  Any help is appreciated.  Thanks

2 answers

Profile photo of Mall Staff 153110.00 $tone September 30, 2020
Public

Hi there,

 I had to instead add the short code to the cms home page in order to at least get the menu to show on the landing page.

That is not needed. 

I am unable to see the mega menu on the other page at https://joomgi.com/sewyeahquilting/ when I added the xml to Magento_Theme/default.xml.

Please note that by default our module shows the Top menu in the ‘store.menu’ position in the ‘page.top’ container. You can see more detailed definition for that in the XML file at: app/code/Ubertheme/UbMegaMenu/view/frontend/layout/default.xml

<referenceContainer name="page.top">
<block class="Ubertheme\UbMegaMenu\Block\Menu" name="main.ub.mega.menu" template="Ubertheme_UbMegaMenu::menu.phtml" >
<arguments>
<argument name="menu_key" xsi:type="string">main-menu</argument>
<argument name="addition_class" xsi:type="string"></argument>
<!-- You could uncomment below line to apply a custom cache lifetime -->
<!--<argument name="cache_lifetime" xsi:type="string">86400</argument>-->
</arguments>
</block>
</referenceContainer>
<!-- Move it to store.menu container-->
<move element="main.ub.mega.menu" destination="store.menu" before="-"/>

It seems that your custom theme has a special case and the default position I mentioned was disabled (the ‘store.menu’ position in the ‘page.top’ container). Please check this at your end again.

In case you need further helps, please provide me information about your instance:

  • URL and admin credentials of your M2 instance
  • SSH credentials of your M2 instance
  • Let me know the path to the M2 folder
  • And let me know more details of the positions you want to show the Top menu.

I will help to check further and get back to you then.
 
PS. Please make sure you mark your reply private or simply switch this ticket to the private mode when sharing your site info. Then, only you and our technical team can access it. 

Regards,
Mall.
 
 

#2

Please login or Register to Submit Answer

Written By

Comments