Flat Catalog Product leads to a critical problem


I have ~17000 products in catalog.

If i enable Flat Catalog Product mode, module doesn’t appear anymore.

I tried to solve the problem myself and finally came to these lines:


PHP Code:

"_reviewed_order_table.store_id=$storeId AND _reviewed_order_table.entity_pk_value=e.entity_id",

The module dies after this line if Flat Catalog Product mode is enabled. Shop still works, but doesn’t show the module.

php memory limit is set to 812M

14 answers

Profile photo of thangnn1510 0.00 $tone July 22, 2011

I’ll follow you in BIQ-582-73223, please close other tickets. I have received your info. Thanks for giving it. I have checked and seen that you forgot to reindex data after change products and category to flat type. Please go to admin -> system -> index manager and click to submit button. I have done this for you and now the category list works well.

Please tell me if you need more help.

Thank you.

Profile photo of Alexey Bezugly 0.00 $tone July 22, 2011

No, it doesn’t work!

It works only for "latest product" and "most viewed". if i choose "most reviewed" it doesn’t show up. i have "most reviewed" module in cms block named "position-10". If i remove the module from the block it works fine, if i put it again, module doesn’t work at all (even html).

The problem is here

"_reviewed_order_table.store_id=$storeId AND _reviewed_order_table.entity_pk_value=e.entity_id" ,

Also there is a similar problem with Product Slider if i choose any variant different from "latest procucts"

1. full-page cache still works even if you "disable" it in the cache manager. so please "refresh" this "Magento Booster" option in the cache management.

2. position-10 renders on the top the second column (under videos) on the home page.

Profile photo of Alexey Bezugly 0.00 $tone August 28, 2011

It’s all the same, You didn’t fix anything. If I use "most-reviewed" option and Flat Catalog Product mode the JmCategoryList module doesn’t show up. For example in in Static Block "position10" (top in the second column on the home page). If i choose any other option it works. Please fix it a soon as possible. Why does it take so long?


Please login or Register to Submit Answer

Written By