UB Atoms and PHP 8.2.x

Hello, we use Atoms 1.0.7. Will you continue to maintain this theme or is it advisable to look for something new? Is it suitable for php8.2 or 8.3? When I tried to switch to PHP 8.2 I got the following error: 1 exception(s): Exception #0 (Exception): Deprecated Functionality: Creation of dynamic property Ubertheme\UbThemeHelper\Framework\Module\Dir\Reader::$componentRegistrar is deprecated (Debian 12, Php 8.2.18, Magento 2.4.6-p2)

1 answer

Profile photo of Ziven Staff 100620.00 $tone May 20, 2024
Public

Hi There,
 

Hello, we use Atoms 1.0.7. Will you continue to maintain this theme or is it advisable to look for something new? Is it suitable for php8.2 or 8.3? When I tried to switch to PHP 8.2 I got the following error: 1 exception(s): Exception #0 (Exception): Deprecated Functionality: Creation of dynamic property Ubertheme\UbThemeHelper\Framework\Module\Dir\Reader::$componentRegistrar is deprecated (Debian 12, Php 8.2.18, Magento 2.4.6-p2)

We’ve updated Atoms, you can check out the latest version’s changelog here. The new version is compatible with Magento CE 2.4.7 and PHP 8.2.
 
Here’s a quickfix for your specific error: Download the latest version of Atoms from the Downloads page, copy the file app\design\frontend\Ubertheme\atoms\web\css\custom\custom.less from the downloaded package to the corresponding folder on your development instance.
 
Then re-deploy the static content.
 

Best Regards,
Ziven.
 
 

#1

Please login or Register to Submit Answer

Written By

Comments