When I try and save setting I get An error occurred while saving the profile!

Installed Megamall. All seems to be working except BaseTheme It has defaulted onto BOXES and if I change to anything else I get “An error occurred while saving the profile!” If I try and change any settings I also get same error. Tried reinstalling but no luck
 
Paul

9 answers

Profile photo of Mall Staff 90320.00 $tone January 14, 2015
Public

Hi Paul Martin,
Please re-check the FTP credential of your site, i can’t connect to server of your site with it.
The password does not match. I need to check directly in server of your site & tell you how to solve that issue.

#3
Profile photo of Mall Staff 90320.00 $tone January 15, 2015
Public

Hi Paul Martin,

except BaseTheme It has defaulted onto BOXES and if I change to anything else I get “An error occurred while saving the profile!” If I try and change any settings I also get same error

This issue due to the permission of file/folder on your site
Temporarily i have chmod the folders & files in path: app/design/frontend/default/jm_megamall/profiles/local/boxes.ini to Folders: 0777 & Files: 0666 (This mean is Other Users can write to folders & files) and the issue as you said was solved.
You should contact to System Admin of your Server & re-config the Apache User, Web Root folder Owner & Folders & Files Permission. The Apache User has to be the same User or Group with User Owner of the web root folder of your website.
And after, you should change mode (chmod) of folders & files to: Folders = 775 & Files = 664
Feel free to contact me if you need further help.

#5
Profile photo of Paul Martin 90.00 $tone January 15, 2015
Public

Many thanks that has fixed that but strange one. Logo on website has reverted to MegaMall. I have copied our logo to skin/frontend/default/jm_megamall/images/logo.gif but it still shows MegaMall -- can you have a look as not sure why this is I thought because this BaseTheme is now working it switches the MegaMall logo when you change the Profile to different colours that my logo should be saved somewhere different?
 
Paul

#6
Profile photo of Mall Staff 90320.00 $tone January 21, 2015
Public

Hi Paul Martin,
As i said at first reply, you have wrong config permission of webroot owner & folders & files mod.
To resolve the issues as you said, you need to contact to your System Admin to help you re-config it.

The Apache User has to be the same User or Group with User Owner of the web root folder of your website.
And after, you should change mode (chmod) of folders & files to: Folders = 775 & Files = 664

Seem you was changed the FTP pass you are provided, so i can’t login again.
Our Theme & Jm Basetheme extension working fine. You try set a website in your local machine to clear this.

#7
Profile photo of Paul Martin 90.00 $tone January 21, 2015
Public

Thanks this is working now problem I am having is on MEGAMENU I have another question open about that. I add Categories to this but sub categories under the category I add don’t appear

#8
Profile photo of Man 410.00 $tone January 23, 2015
Public

Hi Paul Martin,

I add Categories to this but sub categories under the category I add don’t appear

You need to create the sub menu items for each menu item in MegaMenu Management in back-end.
Also, i still see the sub menu in MagegaMenu is showing in your site.

#9

Please login or Register to Submit Answer

Written By

Comments